Informacast

Major incident Informacast
2023-08-16 08:29 AM CDT · 1 week, 1 day, 2 hours, 26 minutes

Updates

Resolved

Issue has been resolved

August 24, 2023 · 10:55 AM CDT
Investigating

Users may be experiencing issues with the PA and Bells cutting out on campuses. Issue has been identified with the vendor who has been working on a patch.

August 16, 2023 · 08:29 AM CDT

← Back