Classlink 404 error

Major incident Portal (Classlink)
2023-08-15 08:49 AM CST · 49 minutes

Updates

Resolved

Portal login issue has been resolved.

August 15, 2023 · 09:38 AM CST
Issue

Launchpad Login issues. Users may experience intermittent login issues or load the Launchpad My Apps page. We are investigating and will post updates as soon as possible.

August 15, 2023 · 08:49 AM CST

← Back