Classlink Launchpad Login Issues

Minor incident Portal (Classlink)
2023-07-13 08:04 AM CST · 3 hours, 17 minutes

Updates

Resolved

This incident has been resolved. For any remaining login issues, please contact helpdesk at x81000

July 13, 2023 · 11:21 AM CST
Investigating

The issue has been identified, and a fix is being implemented. We’ll post another update as soon as one is available.

July 13, 2023 · 08:04 AM CST

← Back