Edugence inaccessible

Major incident Edugence
2023-07-10 08:53 AM CST · 18 minutes

Updates

Resolved

Access to Edugence has been restored. If you are still experiencing issues please contact helpdesk at x81000.

July 10, 2023 · 09:10 AM CST
Investigating

Edugence is currently inaccessible, when trying to login it will show you are trying to login from “Royce City ISD”. Edugence has been engaged and they’re working to swiftly correct the issue. Thank you for your patience.

July 10, 2023 · 08:53 AM CST

← Back