Email Processing Delays

Minor incident Mimecast
2023-06-07 09:34 AM CDT · 2 hours, 25 minutes

Updates

Resolved

Mimecast believes the email delay issue is resolved and any remaining delayed messages should gradually retry and process normally. We will continue to monitor the situation and will post updates here if any further issues are identified.

June 7, 2023 · 11:57 AM CDT
Issue

Our mail security provider Mimecast has posted the following update to their status page https://status.mimecast.com/

[Investigating]
We are aware that some customers hosted on our US and US-B grids may be experiencing intermittent delivery delays and messages may be held in the processing queue. We are currently investigating the issue and updates will be posted here as they become available.

June 7, 2023 · 09:34 AM CDT

← Back