Front Security incident

Major incident Frontline
2023-05-19 11:59 AM CDT · 2 hours, 23 minutes

Updates

Resolved

Frontline has confirmed their security certificate is once again in place and valid. We are opening Frontline services back up, meaning AESOP, 5Lab, and eSped are now available. Thank you for your patience as well as your commitment to security in Northwest ISD! Have a great afternoon and weekend!

May 19, 2023 · 01:22 PM CDT
Issue

If you are currently logged into Frontline (Absence Management or eSPED) please immediately log out. Frontline is having certificate issues and we want to ensure we are protecting student and staff data. Please do not attempt to log in again until we send an update that this issue has been resolved. Thank you for your understanding!

May 19, 2023 · 11:59 AM CDT

← Back