Timeclock Inaccessible

Major incident Timeclock Plus
2023-05-03 02:07 PM CDT · 17 hours, 29 minutes

Updates

Resolved

Timeclock Plus is reporting the login issue is resolved. If you continue to experience issues logging into TCP please contact helpdesk.

May 4, 2023 · 07:36 AM CDT
Issue

We are currently experiencing an outage with Timeclock Plus, which is preventing employees from clocking in and out. TCP is working to resolve the issue as fast as possible.

Timeclock Plus Status

May 3, 2023 · 02:07 PM CDT

← Back