HAC currently down for parents/guardians

Major incident Home Access Center
2023-01-18 10:07 AM CDT · 1 day, 3 hours, 45 minutes

Updates

Resolved

Access has been restored. If you continue to experience issues related to HAC please contact the helpdesk at x81000.

January 19, 2023 · 01:53 PM CDT
Investigating

Please be aware that parent/guardian access to Home Access Center – or HAC – is not currently accessible as our vendor investigates an issue it’s experiencing. In the interim, please remember students can log into HAC by visiting the portal at portal.nisdtx.org for all their grades and attendance needs.

January 18, 2023 · 10:08 AM CDT

← Back