Google services outage

Minor incident Google Suite for EDU Google Admin Google Drive Gmail Youtube
2022-12-13 01:40 PM CDT · 19 hours, 13 minutes

Updates

Resolved

Closing issue, please contact helpdesk if you are still experiencing issues

December 14, 2022 · 08:53 AM CDT
Investigating

We believe the chromebook sign in issue is resolved, if you are still having issues please contact helpdesk.

December 14, 2022 · 08:51 AM CDT
De-escalate

We are hearing of successes for logging into chromebooks across the district, if you were having problems please try again.

December 13, 2022 · 03:48 PM CDT
Issue

Google is experiencing a temporary outage and is effecting logging into google and into chromebooks. We will update when more information becomes available.

December 13, 2022 · 01:47 PM CDT

← Back