Canvas Clients experiencing slow load times and errors

Minor incident Canvas
2022-09-21 01:24 PM CST · 57 minutes

Updates

Resolved

From Canvas - We are continuing to monitor for any further issues.

Canvas Status Page

September 21, 2022 · 02:21 PM CST
De-escalate

From Canvas - A fix has been implemented and we are monitoring the results.

Canvas Status Page

September 21, 2022 · 01:38 PM CST
Investigating

From Canvas - We are continuing to investigate this issue.

Canvas Status Page

September 21, 2022 · 01:25 PM CST

← Back